Theword will not launch since Yosemite
Page 1 of 2

Author:  fokneel [ Wed Oct 22, 2014 12:44 pm ]
Post subject:  Theword will not launch since Yosemite

I upgraded to Yosemite and now Theword app attempts to launch but then stops and never launches. I have tried restarting my computer and I even reinstalled theword this morning.
Anyone else having trouble with Yosemite.
macbook pro mid 2010.

Thank you

Author:  fokneel [ Wed Oct 22, 2014 11:20 pm ]
Post subject:  Re: Theword will not launch since Yosemite

Hi Costas,
Any help here would be appreciated. Any idea why the app wont launch? I also deleted and reinstalled, theWord and xquartz to no avail.


Author:  csterg [ Thu Oct 23, 2014 8:15 am ]
Post subject:  Re: Theword will not launch since Yosemite

Sorry Frank, i have no idea (and i don't have access to a MAC with Yosemite). I am sure it is nothing too serious, but someone with some experience on MAC should help.

Author:  fokneel [ Fri Oct 24, 2014 12:00 am ]
Post subject:  Re: Theword will not launch since Yosemite

Thanks Costas,
52 views so far. :( no help.

Author:  zhage [ Fri Oct 24, 2014 2:41 am ]
Post subject:  Re: Theword will not launch since Yosemite

Hi, I am working on it. Hopefully something before the end of the week.

Author:  fokneel [ Fri Oct 24, 2014 5:39 am ]
Post subject:  Re: Theword will not launch since Yosemite

Thank you!


Author:  zhage [ Fri Oct 24, 2014 6:35 am ]
Post subject:  Re: Theword will not launch since Yosemite

Hi Frank and other early Yosemite adopters,

It seems that it is difficult to get it to work after upgrading. At least I could not find a very simple way. Then I tried a different WINE package that WillysJeepMan had referred to earlier. It worked!! It will take about 45 minutes. I think it is best to back up your WORD files and delete the entire Mac package before doing this.
Here are some initial instructions that I prepared for our students.

Hope it helps! Blessings.

Using Wineskin Winery

(BTW WINE is an acronym: Wine Is Not an Emulator)

Thanks to WillysJeepMan who shared this method on the forum before, on 28 July 2014. I simply tried it out for Yosemite and added some instructions. Thanks!

Wineskin Winery is a program that has several advantages: 1. It is free, 2. You do not need a Windows license, 3. It works with Yosemite, 4. TheWORD can be packaged inside a so-called Wrapper and shared with others.

What the Wineskin Winery App does is to create a Windows style wrapper in which you install your desired Windows program. You can create as many wrappers as you want for different Windows programs. They function as stand-alone programs inside a single wrapper. You can even put them on your dock and you would hardly notice it is a Windows program!

Installing the wineskin (the wrapper-creating App) is initially a little awkward but it seems to work, both for Mavericks and Yosemite!!

Go to:

Click on the Downloads tab and select download file.

In your downloads folder there is now a file called Wineskin Winery App

Double click, click OK for downloaded file from internet and install.

Add an engine, select the newest and click download and install.

Now you have one item under installed engines

Now click on Update under wrapper.

It usually does not work the first time, but I left other programs running while installing. This does not work! So close all programs and then open the Wineskin Winery App again. It is still inside the downloads folder. Try again to Update under wrapper. It should work, sometimes after a few times.

Then click on create a new blank wrapper, the option is now not greyed out any longer.

Give it a name. You could choose Book Study or even TheWORD (rather than ‘MyCoolWrapper’).

Wait while it is being updated

Then a window states that something could not be found, something .NET. Click Install and it will download the Wine Mono Installer.

Next is a message regarding Gecko. Just hit Cancel.

Then wait while busy etc. It may disappear behind a finder window, just wait and it should start popping up and down in the dock, indicating it is done.

The Wrapper is finished, with the name you originally gave. At this time you should close the Wineskin Winery program, otherwise you end up with two similar looking icons in the Dock, one is called Winery (the full name of the App is the Wineskin Winery), and an other one (that you will open soon and looks very similar and is labeled with a name that you gave; I suggested ‘Book Study’).

The original wrapper creating app is still located in the downloads and you can run it from there, but it is better to move it to the regular Applications folder, where all other Mac Apps reside. (Macintosh HD -> Applications). You do not need this program any more until you want to create another wrapper that holds a different Windows-based program that you may want to use on your Mac.

The other one, the ‘Book Study’ App is located somewhere else: Go to your home folder, then to the (different!) Applications folder in there. There should be just one folder/program there. This is the path: (Macintosh HD -> Users -> Home Folder -> Applications -> Wineskin -> Book Study App)

Now we need to actually install the program inside this ‘Windows Wrapper’ that you just created. You need to open this App, either double clicking, hitting Command Arrow Down or Right-click on the Book Study App and select Open. The options given here work in Mavericks or Yosemite, but I noticed that not all three work in both iOSes. Then a small window comes up where you click Install Software. The next window is the Installer. Click on the Choose Setup Executable. Then you browse to the place where your ‘theword-setup-en.exe’ file is located. Initially it is best to use the starting package downloaded from the internet, the regular Windows one.) Click Choose and it should start! (Message says: Wineskin is currently busy, Please wait...)

The first window that comes up is “theWord Installation”, click on Next, then on I agree. Next window concerns the type of installation, keep it on the default ‘Normal’ and click Next again. Then Next again (Here all Add-on resources should have a green tick next to them). Then Install in the default C:\Program Files\The Word folder, which is already given as the standard option. The last window is the one where you simply click on Finish to complete the installation and Run the program for the first time. The Option to Run the Word is already selected by default.

Open the program and everything should be there. Now click on File (the Windows style menu bar at the top of the TheWORD program, not on the menu bar on top of the Mac screen!). Close it. You are done!

At this point you want to add your own modules of course, since this is just the basic package from the website. You need to know where the program is and where those modules are located and how you can copy them over.

This is the path:
/Users/”your home folder”/Applications/Wineskin/Book Study app/Contents/Resources/drive_c/users/Public/Application Data/The Word/ (Once you are in here you see the familiar folders: Books, Bibles, Cache, Misc, Templates and Backgrounds.)

In the middle you see Book Study app (or whatever name you did), you need to right-click on the app and choose Show Package contents, then, only then, can you dig deeper into the file structure.

It is possible to actually change the icon of the Book Study App, so that it looks like the TheWORD icon. This is how you do that:
Select the blue TheWORD icon at the beginning of this document/from the Internet and copy it. Then go to the Book Study Ap in a Finder window. Click on the App once, and then click Command-i. In that new information window that pops up click once on the brown icon at the top-left. (not the very small icon next to the red-orange-green buttons, but the one slightly larger underneath, next to the name of the App.) You will see a small selection stroke around the icon. Now simply do a Command-v and the blue icon you selected earlier will replace the brown Winery one.

To open this program you will have to right click on the icon and select ‘Open’. For some strange reason it does not respond to double clicking on my computer. However if you move the Book Study App to the Dock it will open normally.

Also, a window may come up asking you to specify or confirm what exe file you want to associate with this wrapper. Just choose the exe file referred to earlier that is now somewhere deep inside your App file structure, but normally it already suggests that file and its location is given too.

Hope this helps.

Next week I will have an extended version of this for our students including a Keynote. If interested let me know.

Author:  fokneel [ Sun Oct 26, 2014 4:45 pm ]
Post subject:  Re: Theword will not launch since Yosemite

Thanks Zhage. The first attempt did not work but I tried a couple of times and I now have the "book study" icon and it opens the application with the initial books. However I cannot find any of my hundreds of modules. I looked for your path but could not find it.

Thanks for any help on this.

If I cannot retrieve my modules on my Mac, can I re-download my paid modules? How do I do that?

Thanks and Blessings
Screen Shot 2014-10-26 at 10.24.13 AM.png
Screen Shot 2014-10-26 at 10.24.13 AM.png [ 103.69 KiB | Viewed 8686 times ]

Screen Shot 2014-10-26 at 10.27.46 AM.png
Screen Shot 2014-10-26 at 10.27.46 AM.png [ 101.08 KiB | Viewed 8686 times ]

Author:  fokneel [ Sun Oct 26, 2014 5:03 pm ]
Post subject:  Re: Theword will not launch since Yosemite

I just tried to download and install modules. They download as .exe files and will not open when I click on them because they are windows files. Do I install them into a new "wrapper" or is there a way to get them into the one already created "book study"

Thank you

Author:  zhage [ Sun Oct 26, 2014 5:25 pm ]
Post subject:  Re: Theword will not launch since Yosemite


Glad it works so far! You cannot install by double-clicking exe files, you realized that! However, just like on a regular Windows computer, all the files are located inside this TheWord folder. Inside your BIBLES folder you simply dump all your Bibles, and then you create a new folder BOOKS inside the same TheWORD folder, next to the BIBLES folder. In that newly created BOOKS folder you put all other modules, irrespective whether they are books, dictionaries or anything else.
I did not know what exe file you had used, apparently just a basic one. I just downloaded the regular Word V. 4 from the website, (the 50 some MB Windows package), so after the initial installation there are already several Bibles and a couple hundred books in place. Then you just add the ones you want from your own module collection. It should even accept locked modules, but will ask for the unlock code since this is considered a new installation on a new computer.
If you prefer to install using the installer inside TheWORD, you need to make sure that you put all your modules in a big folder inside the drive C, so that you can find them inside this Windows wrapper. The TheWORD program inside the Winery wrapper can only 'see' what is inside the c: drive.

Have a blessed Sunday, or whatever is left of it in your location!

Author:  Oakd2k [ Sun Oct 26, 2014 8:32 pm ]
Post subject:  Re: Theword will not launch since Yosemite

Yes, have discovered the same problem. The instructions seem somewhat difficult and problematic. In the coming week, would there be a more simplified set of instructions for those of us not computer tech types?

Author:  fokneel [ Mon Oct 27, 2014 2:17 pm ]
Post subject:  Re: Theword will not launch since Yosemite

Agreed! But thanks for all the information. Can you be more specific on how to install new modules?

Thanks and blessings

Author:  zhage [ Mon Oct 27, 2014 4:06 pm ]
Post subject:  Re: Theword will not launch since Yosemite

Hi Frank,
I did edit my previous posts a little bit, hope it is clearer now, but admittedly not super simple.
It is best to install the official installer package from Costas' website, (the regular Windows one, not the Mac version!). That way you already have the basic structure of the program and its Bibles-Books-Cache-Misc folder etc. in place.

The easiest way to install 'hundreds of modules' is to have two Finder windows open next to each other. In the first window you have your collection of hundreds of modules, perhaps on a flash disk, and in the other one you have the following path open:
/Users/”your home folder”/Applications/Wineskin/Book Study App/Contents/Resources/drive_c/users/Public/Application Data/The Word/ …(here are your Bibles and Books folders and a few others).

Now you select all the Bibles you want to add to the few that are installed in the base package and put them right in the Bibles folder at the end of the path just mentioned. Next, you select all other modules, whether dictionaries, commentaries or general books and put those in the Books folder. You put all the modules in there, not the folders in which you have them stored, otherwise you get Bible folders inside other Bible folders. So individual books go straight into the Books folder, and likewise for Bibles.
Then you restart the TheWORD program and although it may need some time to index those hundreds of new resources, they should all be accessible from now on.

Author:  fokneel [ Mon Oct 27, 2014 6:02 pm ]
Post subject:  Re: Theword will not launch since Yosemite

Hi Ahage,
Thank you. I don't know what I did wrong. I cannot find any of my previous modules. Some of them were paid modules. ouch.

Additionally when I search finder for the the books in theWord, the path only goes as far as BoosStudy and no further.

I pasted a screen shot to this post.

Finally it seems I will need to download my old modules but winery does not seem to show an option to do that. Can you offer any help with that?

Thanks and blessings.


Screen Shot 2014-10-27 at 11.58.34 AM.png
Screen Shot 2014-10-27 at 11.58.34 AM.png [ 83.08 KiB | Viewed 8643 times ]

Author:  zhage [ Tue Oct 28, 2014 2:35 am ]
Post subject:  Re: Theword will not launch since Yosemite

Hi Frank,

Let me clear up the confusion: When you installed Wineskin Winery and then installed the official TheWORD package from Costas' website you only installed the engine, and a few standard modules that come with that package. The Wineskin Winery method is totally different from an earlier Mac installation. It will not be able to locate these modules by itself. You must put them in yourself. Could you tell me what exactly is inside your BookStudy App? In order to see the contents you need to right-click on the App and choose Show Package Contents (see one of the previous emails). The contents should be what I said in yesterday's email.

Now, as far as your old modules go, they are in a back-up drive I hope. I said to make a back-up of all your modules, and then delete the older Mac package since it does not work with Yosemite. If you did not make a back-up or do not have them stored in the Cloud somewhere AND you did delete the older package then you will simply have to start downloading your modules all over again. That may take some time, but it does mean you will have the newest versions of all of them :)

However, if you did not delete the old Mac package it may still be on your computer. However, as with the Wineskin method anything Windows is hidden from view in the Finder and is not searchable either.
The path for the older package is here: Macintosh HD/ Users/ Home Folder/ Library/ Application Support/ Wine/ Prefixes/ theWord/ drive_c/ Program Files/ The Word/
NB: When you open in a Finder window, you will not see the Library folder as it is part of the hidden file structure on a Mac. This is what you do: Open a Finder window, choose the Go menu at the top, then scroll down to Go to Folder... and it should open by default to ~/Library. If not, then that is what you type in the box, click Go and it should take you to the desired Library folder. If you find your modules there copy them over to a USB stick (as a back-up!) and now you can start copying them to the new Wineskin Winery wrapper inside your Book Study App; see above. Hope this helps.

Page 1 of 2 All times are UTC + 2 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group