Page 1 of 1

TRa 2.5 lemma lookups in LSJ, MLSJ don't work on Ubuntu

Posted: Mon Oct 17, 2016 7:32 pm
by Adelphe
I don't think this is a problem that will affect very many people, but I was wondering if anyone might know of a work-around.

When I click on a word in the TRa version 2.5, the Strong's displays the correct entry, but the LSJ and MLSJ (based on the lemma) do not. I kept and renamed version 1.3 of the TRa (I'm using both) and the LSJ/MLSJ do display correctly for that version of the TRa on Linux. I tested the current TRa version (2.5) on a Windows 7 installation I have available, and it works fine there, so evidently this is a problem with the TRa version 2.5 on Linux/Wine. I'm using Ubuntu 12.04, Wine version 1.4.

Other details: Sometimes the lemma is truncated -- for example, when I click on the Greek "καὶ", the LSJ goes to "κα". When I click on some prepositions in the TRa, the LSJ displays the correct entry.

I have tried removing the TRa version 1.3, on the theory that there might be some kind of conflict, but it made no difference.

Any ideas would be appreciated.

Thanks for your hard work on this awesome software! :)

Re: TRa 2.5 lemma lookups in LSJ, MLSJ don't work on Ubuntu

Posted: Wed Oct 19, 2016 3:22 pm
by therapon
I have had this (or a very similar) problem for several years. See this thread: viewtopic.php?f=8&t=4608 For me, it is an indexing problem - the entries TW puts in the dictionary index when it builds it on the first run. From the next to last post in the thread, "It appears to be a problem of handling the normalization form of the Greek with accents." To my knowledge there is no fix for it yet.


UPDATE: I just did a little more investigating. Rebuilding the LSJ search index on Win8 changes the lookup results. It fixes some of the problems but not all. Clicking on "καὶ" goes to the right entry in Dictionary view, but in the hover popup the entry is "κα". Another example: clicking on "τάδε" goes to the correct entry in Dictionary view but nothing appears in the hover popup. It is the same when running TW either on Win8 or Kubuntu. Rebuilding the index on Kubuntu reverts to the other "more broken" behavior.

Kubuntu 14.04, Wine 1.9.20, theWord

Re: TRa 2.5 lemma lookups in LSJ, MLSJ don't work on Ubuntu

Posted: Fri Oct 21, 2016 10:47 pm
by Adelphe
Thanks so much for your reply, therapon! I remember looking at that thread when I first started looking for a solution. I rebuilt the index for the LSJ, but I didn't see any difference. The problem does seem very similar to yours, though -- especially the truncated kai.

When I do a right click to look up the lemma in TRa 2.5, the LSJ and MLSJ are not even on the list of available dictionaries. (The strange thing is that the old version of the TRa shows both. I happened to have it because I use it to print for some tutoring I'm doing, and I wanted a version without punctuation.) But on a rare occasion, clicking on certain words in the TRa 2.5 does work as it should, the hover popup displays correctly, and both dictionaries appear in the list when I right-click and look up the lemma.

So far, I've been working around the problem by having both the TRa 2.5 and TRa 1.3 open in a compare view, and using version 1.3 for the lemma lookups. So it's not really a big problem -- except that I can't seem to stop fiddling with it to see if I can find a solution. :D

I didn't do any extensive testing on Windows 7 because I almost never use it. I just copied TW to a flash drive and clicked a few words in the TRa version 2.5, and it worked in those cases.

Thanks again for chiming in! :)

ps - The final iota is always missing in my RWP module as well. Maybe there are two different problems here.