[www.theword.net]

Twitter live feed  
View unanswered posts | View active topics It is currently Wed Jun 16, 2021 6:46 pm



Reply to topic  [ 15 posts ] 
 Correct detecting verse but Wrong position for Non-Eng Ref. 
Author Message

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Correct detecting verse but Wrong position for Non-Eng Ref.
Dear Costas,

When I let TW to auto-detect verse references (with Ctrl+Shift pressed for references without prior book name), TW in some case will correctly detect it, but then put the hyperlink is wrong position, for Non-English books.
I use Eng ref as a demo:
"I think that 1:2 means ...."
TW may put the hyperlink on the word "means", instead of "1:2".

I have attached a demo file for your testing purpose.

Since TW can correctly detect the reference actually, I suppose this is an easy bug to be resolved. Hope you can solve it.


Attachments:
CUVL_Demo.cmt.twm.zip [6.01 KiB]
Downloaded 224 times


Last edited by patwwh on Sun Apr 17, 2016 10:15 am, edited 1 time in total.

Sun Apr 17, 2016 3:23 am
Profile
User avatar

Joined: Wed Jun 04, 2008 7:34 pm
Posts: 4179
Post Re: Correct detecting verse but Wrong position for Non-Eng R
So, what language are you using? Can you post a sample that has the problem please.

_________________
Jon
the
Word 5 Bible Software
OS for testing; Windows 10
Beta Download ------Beta Setup Guide------On-line Manual------Tech doc's and Utilities------Copyright Factsheet


Sun Apr 17, 2016 9:20 am
Profile

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
I find that .twm file cannot be uploaded directly, so I have zip and re-uploaded it again.
I am using Traditional Chinese.


Sun Apr 17, 2016 10:17 am
Profile

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Any reply?


Tue Apr 19, 2016 10:30 am
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8610
Location: Corfu, Greece
Post Re: Correct detecting verse but Wrong position for Non-Eng R
I took a look at the file. I cannot really understand what is going on. I tried to change the interface language to Chinese but nothing is detected. You should try to create a simpler example with a very specific use case.
Costas


Sat Apr 23, 2016 4:58 pm
Profile WWW

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Hi Costas,

The file I uploaded previously was a auto-detected module, containing just a small table.
If it is not simple enough for your testing, here I zip a file for you, with content in ONE line only. Both original version and auto-detected versions are inside.


Attachments:
Two_Files.zip [8.08 KiB]
Downloaded 232 times
Sun Apr 24, 2016 6:55 pm
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8610
Location: Corfu, Greece
Post Re: Correct detecting verse but Wrong position for Non-Eng R
OK, i still need help.
First, i cannot make the detection to work at all. Which language is your interface in?
Second, what should be detected exactly?

Also, what version of theWord are you running?


Sun Apr 24, 2016 7:55 pm
Profile WWW

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Hi Costas,

I am using TheWord v5 + Language Pack v5, which is Traditional Chinese Lang Pack as I mentioned in previous posts. I have also tried to completely removed, reinstalled, and re-tested TheWord before I made this series of posts.

As I described in my 1st post, the problem occurs for references without book name.
Replacing Traditional Chinese by English for your understanding below:

e.g. 1:2, instead of Gen 1:2.

When I auto-detect the references with Ctrl+Shift pressed, then
"A. Human History 1:1-11:9 / I. God Creation 1:1-2:25"
incorrectly becomes:
"A. Human History 1:1-11:9 / I. God Creation 1:1-2:25"
instead of the expected correct one like:
"A. Human History 1:1-11:9 / I. God Creation 1:1-2:25"

The hyperlink of 1:1-11:9 is incorrectly built on the the phrase "I. God Creation", but not "1:1-11:9".

Although your Windows may not be able to show Traditional Chinese, you should be able to observe the Ansi characters and numbers, as well as the changes in hyperlinks built with blue color, in my last shared 2 modules. For your convenience, I have also attached a screenshot for you in this post. Upper window shows the original plain module. Lower window show the auto-detected module. The position of the blue text would tell you everything.

N.B. The Windows used is Win10. If you are using Win10 too and want to view Traditional Chinese characters, you can actually change the Region setting for Non-Unicode Program to Traditional Chinese, since Win10 is natively a multi-language version.


Attachments:
BeforeVsAfterDetection.jpg
BeforeVsAfterDetection.jpg [ 159.19 KiB | Viewed 2431 times ]
Mon Apr 25, 2016 3:07 pm
Profile

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Hi Costas, is there still any unclear area?
May we expect a debugged version?


Sat Apr 30, 2016 11:17 am
Profile
User avatar

Joined: Wed Jun 04, 2008 7:34 pm
Posts: 4179
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Do you hold down the Shift and Ctrl key also?

_________________
Jon
the
Word 5 Bible Software
OS for testing; Windows 10
Beta Download ------Beta Setup Guide------On-line Manual------Tech doc's and Utilities------Copyright Factsheet


Sat Apr 30, 2016 12:48 pm
Profile

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Hi JG, yes, I have mentioned twice that I have pressed Ctrl+Shift. I am very experienced in these procedure. The problem is not that I cannot detect the verse, but the detected result are imposed on wrong position. Please see my last posts.


Sat Apr 30, 2016 4:40 pm
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8610
Location: Corfu, Greece
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Dear patwwh,
the bug has been fixed in b1469. Please download from beta section and let me know if it works for you.
Thanks for reporting in such a detailed manner and being patient until I 'got' it :)
Costas


Mon May 02, 2016 10:49 am
Profile WWW

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Dear Costas,
I have downloaded the latest b1470.
Unluckily, not successful. 2 out of 6 have problems.
Attachment is the updated result.
Pat


Attachments:
Demo.cmt.twm.zip [2.12 KiB]
Downloaded 197 times
Mon May 02, 2016 10:01 pm
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8610
Location: Corfu, Greece
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Pat,
I did an additional fix in b1471. Can you try it out please?
Thanks
Costas


Tue May 03, 2016 4:55 pm
Profile WWW

Joined: Thu Sep 24, 2009 2:00 pm
Posts: 32
Post Re: Correct detecting verse but Wrong position for Non-Eng R
Dear Costas, problems have been resolved. Thanks for your help.


Wed May 04, 2016 5:21 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 15 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.823s | 17 Queries | GZIP : Off ]