[www.theword.net]

Twitter live feed  
View unanswered posts | View active topics It is currently Sun Oct 17, 2021 6:58 am



Reply to topic  [ 14 posts ] 
 suggestion: stop display while layout is loading 
Author Message

Joined: Tue Nov 03, 2009 5:49 pm
Posts: 230
Post suggestion: stop display while layout is loading
I was showing theWord to some friends and I changed layouts. The screen displayed all kinds of activity, with views opening first at the bottom then shifting to new locations. Brief, seemingly-disjointed activity.

My friends were disconcerted, wondering if the program was having a breakdown. After the new layout loaded, they said it looked unpolished. Even as an experienced TW user, I find this frenetic choreography unpleasant.

Would it be possible to turn off displaying all that activity when loading layouts?

WORDsearch had this problem at one time -- only much worse. When they turned off all the activity it looked like a more professional product. (I'm not saying TW does not look and act professionally -- just that there is always room to improve.)

Thanks.


Fri Jul 22, 2016 5:02 pm
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8611
Location: Corfu, Greece
Post Re: suggestion: stop display while layout is loading
Interesting. Actually, theWord is supposed to do exactly that :)
I assume that my PC is probably fast and i don't notice the blinking you are noticing. Is that the case?


Sun Jul 24, 2016 11:03 pm
Profile WWW
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8611
Location: Corfu, Greece
Post Re: suggestion: stop display while layout is loading
One more thing: can you display the 'Use skinned window border' if you have it enabled? Do you get the same behavior again?


Sun Jul 24, 2016 11:04 pm
Profile WWW
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8611
Location: Corfu, Greece
Post Re: suggestion: stop display while layout is loading
It may also be related to your OS... what is your OS?


Sun Jul 24, 2016 11:05 pm
Profile WWW

Joined: Tue Nov 03, 2009 5:49 pm
Posts: 230
Post Re: suggestion: stop display while layout is loading
I am using windows 10.

I had the skin set to "no skin". I chose "theWord Default Theme" and the choreography stopped.

I'm not a big fan of themes because they usually strike me as a monochrome mush. So I generally turn them off if I can, trying to maintain the colors I set up in windows.

Skins in theWord are better than most other programs I've tried, though.

Thanks for the fix.


Mon Jul 25, 2016 1:19 am
Profile

Joined: Tue Nov 03, 2009 5:49 pm
Posts: 230
Post Re: suggestion: stop display while layout is loading
csterg wrote:
One more thing: can you display the 'Use skinned window border' if you have it enabled? Do you get the same behavior again?


I thought it was fixed by using a skin. But that was premature (and disappointing) -- I'm still experiencing the problem.

I'm not sure what the 'Use skinned window border' is or how to access it. Can you counsel me please?

The problem is in Athens and Dream skins so I assume it is the same for others. I'll wait to hear how to access 'Use skinned window border'.

video : https://www.dropbox.com/s/rjx9t474xvt7c ... s.wmv?dl=0


Mon Jul 25, 2016 1:32 am
Profile

Joined: Mon Jul 13, 2009 7:56 pm
Posts: 412
Location: Wind River Range, WY
Post Re: suggestion: stop display while layout is loading
You're using the beta. The skinned border option was changed in beta 1461.
Quote:
removed the 'Skinned Window border' option because it brought too many problems, especially in newer version of Windows. A 'legacy' option has been added in the config.ini, namely 'skin.caption.enable=1' that will enable the old behavior, if desired. There is no promise for future maintenance of this legacy mode though.
Looks like it may still be active. Either close the beta, then open the stable version (1450) and uncheck "use skinned border" at the top of the View>Skin menu that you were using, then close before opening the beta, or edit the config.ini file as above (change the "1" to "0").

_________________
Jeff


Mon Jul 25, 2016 3:44 am
Profile

Joined: Tue Nov 03, 2009 5:49 pm
Posts: 230
Post Re: suggestion: stop display while layout is loading
Jeff wrote:
You're using the beta. The skinned border option was changed in beta 1461.
Quote:
removed the 'Skinned Window border' option because it brought too many problems, especially in newer version of Windows. A 'legacy' option has been added in the config.ini, namely 'skin.caption.enable=1' that will enable the old behavior, if desired. There is no promise for future maintenance of this legacy mode though.
Looks like it may still be active. Either close the beta, then open the stable version (1450) and uncheck "use skinned border" at the top of the View>Skin menu that you were using, then close before opening the beta, or edit the config.ini file as above (change the "1" to "0").


Great. Thanks.

I followed your directions and it works as I hoped it would. Sorry for the confusion with the beta.


Mon Jul 25, 2016 3:58 am
Profile

Joined: Tue Nov 03, 2009 5:49 pm
Posts: 230
Post Re: suggestion: stop display while layout is loading
Whenever I initially load theWord, I get no frenetic screen activity when swapping layouts. But at some point it goes back to frenetic mode.

I have been able to replicate using this recipe
    load TW (mine opens to 2 views, side-by-side)
    double click a view's title bar (to maximize view)
    view > layout > different layout

that's when the frenetic layout swapping occurs -- following the view maximization.

beta ...1475


Thu Jul 28, 2016 5:17 am
Profile
User avatar

Joined: Wed Jun 04, 2008 7:34 pm
Posts: 4234
Post Re: suggestion: stop display while layout is loading
verified in beta 1478 by following instructions above.

_________________
Jon
the
Word 5 Bible Software
OS for testing; Windows 10
Beta Download ------Beta Setup Guide------On-line Manual------Tech doc's and Utilities------Copyright Factsheet


Thu Jul 28, 2016 8:32 am
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8611
Location: Corfu, Greece
Post Re: suggestion: stop display while layout is loading
Fixed in b1479.

Thank you kenfhill84083 for being so diligent to report the bug and find a way to reproduce it!
It appears this was a long-standing bug that could cause major flickering in similar cases.

Jon, I would appreciate some testing here, especially in cases of layout/view changes (e.g. add a new view, delete, move around views, toolbars, etc) to make sure that nothing is broken. A broken behavior would make part of the interface to appear unresponsive (e.g. no painting of part of the interface, etc)
Costas


Wed Aug 03, 2016 9:12 am
Profile WWW
User avatar

Joined: Wed Jun 04, 2008 7:34 pm
Posts: 4234
Post Re: suggestion: stop display while layout is loading
Costas, I have not seen any more than the normal flickering, so it is ok.

_________________
Jon
the
Word 5 Bible Software
OS for testing; Windows 10
Beta Download ------Beta Setup Guide------On-line Manual------Tech doc's and Utilities------Copyright Factsheet


Wed Aug 03, 2016 7:34 pm
Profile

Joined: Tue Nov 03, 2009 5:49 pm
Posts: 230
Post Re: suggestion: stop display while layout is loading
JG wrote:
Costas, I have not seen any more than the normal flickering, so it is ok.


I have been playing around in 1479 -- nothing like you guys I'm sure -- and it is working great. :!: :D


Wed Aug 03, 2016 8:05 pm
Profile
Site Admin

Joined: Tue Aug 29, 2006 2:09 pm
Posts: 8611
Location: Corfu, Greece
Post Re: suggestion: stop display while layout is loading
Great!


Thu Aug 04, 2016 9:33 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.828s | 11 Queries | GZIP : Off ]