Version 6

From here you can check the latest version of the software and related apps (e.g. Importer utillity). New add-on modules will be announced here also (Bibles, commentaries, dictionaries, etc)
UBC4ME
Posts: 153
Joined: Mon Nov 02, 2009 2:43 am
Location: Greenville, South Carolina

Version 6

Post by UBC4ME »

Will version 6 ever be available for download through theWord "check for newer version"?
Dave
Gods gifts comes wrapped many different ways.
User avatar
JG
Posts: 4403
Joined: Wed Jun 04, 2008 8:34 pm

Re: Version 6

Post by JG »

Checking for what is happening.
Jon
the
Word 6 Bible Software
OS for testing; Windows 10
Beta Download ------Beta Setup Guide------On-line Manual------Tech doc's and Utilities------Copyright Factsheet
csterg
Site Admin
Posts: 8626
Joined: Tue Aug 29, 2006 3:09 pm
Location: Corfu, Greece
Contact:

Re: Version 6

Post by csterg »

Yes it will.
THere are a couple of issues (like high-dpi compatibility) that I would like to change before activating the auto-update
Costas
UBC4ME
Posts: 153
Joined: Mon Nov 02, 2009 2:43 am
Location: Greenville, South Carolina

Re: Version 6

Post by UBC4ME »

Thank you for the update. Appreciate all you do!!
Dave
Gods gifts comes wrapped many different ways.
therapon
Posts: 309
Joined: Thu Jul 26, 2007 9:39 pm

Re: Version 6

Post by therapon »

I have been using TW with WINE on Linux for years now, mostly with great success. Something has come up just recently, I don't know if it is related to the high-dpi thing or not. Two updates happened at about the same time: from WINE 7.15 to 7.16 and an update to glibc (openSUSE Tumbleweed) which caused thousands of packages to be recompiled.

Anyway, here's the problem: I have for years adjusted WINE dpi scaling from 96dpi to 110dpi with no issues. After the OS updates, TW no longer runs at the higher dpi setting. If I revert to 96dpi using winecfg, all is well (except font size :? ) If I set it at anything larger than 96dpi, TW will not start. I get a funny little box in the upper left of the screen with a piece of the splash screen in it which never changes and the program keeps running at 10-12% cpu load. I tried creating a new WINE prefix and doing a minimal TW install with the same results. If I try running TW in a virtual desktop, the splash screen appears centered on the upper left corner and the program eventually stops responding. All other applications function properly in WINE.

If there is any particular testing/troubleshooting I can do that would be helpful, let me know.

therapon
csterg
Site Admin
Posts: 8626
Joined: Tue Aug 29, 2006 3:09 pm
Location: Corfu, Greece
Contact:

Re: Version 6

Post by csterg »

Can you try to get the latest beta and try this? In the latest beta i have reverted the high-dpi support in the manifest.
therapon
Posts: 309
Joined: Thu Jul 26, 2007 9:39 pm

Re: Version 6

Post by therapon »

Sorry, should have noted that I am using 1529. That is the latest one, correct?

therapon
csterg
Site Admin
Posts: 8626
Joined: Tue Aug 29, 2006 3:09 pm
Location: Corfu, Greece
Contact:

Re: Version 6

Post by csterg »

Yes this is it. I don't have an idea to be honest.
The 10-12% cpu shows that something is looping there, but I can't imagine what that might be.

Do you have any other tools to troubleshoot this? I don't know wine to be honest.
Costas
therapon
Posts: 309
Joined: Thu Jul 26, 2007 9:39 pm

Re: Version 6

Post by therapon »

Starting a few applications from the command line shows nothing odd for TW. Pretty much the usual stuff for things in WINE.

I'm not skilled at reading system calls but I started TW with strace and logged the output to a file. I let it run until it started looping, then stopped it. The log file gets big very quickly! It's about 28MB, here's a link if it would be helpful for you to look at it: https://drive.google.com/open?id=10yvNv ... Zle754KEZM

therapon
therapon
Posts: 309
Joined: Thu Jul 26, 2007 9:39 pm

Re: Version 6

Post by therapon »

It appears to be a WINE issue for me at least. Downgraded from WINE 7.16 to 7.12 and TW works as before. Hopefully that means glibc was not the culprit. Still don't know what the change was in WINE that caused the breakage.

therapon
therapon
Posts: 309
Joined: Thu Jul 26, 2007 9:39 pm

Re: Version 6

Post by therapon »

It was a regression in WINE 7.16, fixed in 7.17 (https://bugs.winehq.org/show_bug.cgi?id=53601)
Post Reply